src/Makefile.am

changeset 252
6342cbbd1922
child 253
e19825a1430a
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/Makefile.am	Wed Oct 18 12:03:44 2017 +0200
@@ -0,0 +1,30 @@
+lib_LTLIBRARIES = libucx.la
+libucx_la_SOURCES = utils.c
+libucx_la_SOURCES += list.c
+libucx_la_SOURCES += map.c
+libucx_la_SOURCES += avl.c
+libucx_la_SOURCES += properties.c
+libucx_la_SOURCES += mempool.c
+libucx_la_SOURCES += string.c
+libucx_la_SOURCES += test.c
+libucx_la_SOURCES += allocator.c
+libucx_la_SOURCES += logging.c
+libucx_la_SOURCES += buffer.c
+libucx_la_SOURCES += stack.c
+
+ucxdir = $(includedir)/ucx
+ucx_HEADERS = ucx/allocator.h
+ucx_HEADERS += ucx/avl.h
+ucx_HEADERS += ucx/buffer.h
+ucx_HEADERS += ucx/list.h
+ucx_HEADERS += ucx/logging.h
+ucx_HEADERS += ucx/map.h
+ucx_HEADERS += ucx/mempool.h
+ucx_HEADERS += ucx/properties.h
+ucx_HEADERS += ucx/stack.h
+ucx_HEADERS += ucx/string.h
+ucx_HEADERS += ucx/test.h
+ucx_HEADERS += ucx/ucx.h
+ucx_HEADERS += ucx/utils.h
+
+

mercurial