configure.ac

changeset 51
5acf05940667
parent 48
0d2c13c24fd0
child 52
02816cd75edc
--- a/configure.ac	Wed May 31 12:32:22 2017 +0200
+++ b/configure.ac	Wed May 31 12:51:24 2017 +0200
@@ -29,7 +29,7 @@
 
 # Conditionals
 AC_ARG_ENABLE([debug],
-[  --enable-debug    Turn on debugging],
+[  --enable-debug          Turn on debugging],
 [case "${enableval}" in
   yes) debug=true ;;
   no)  debug=false ;;
@@ -37,13 +37,13 @@
 esac],[debug=false])
 AM_CONDITIONAL([DEBUG], [test x$debug = xtrue])
 
-# Checks for programs.
+# Compiler (empty default options)
+${CFLAGS=""}
 AC_PROG_CC
-
-# Checks for libraries.
+AC_PROG_CC_STDC
 
 # Checks for header files.
-AC_CHECK_HEADERS([stdlib.h string.h])
+AC_CHECK_HEADERS([stdlib.h string.h dirent.h regex.h])
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_CHECK_HEADER_STDBOOL

mercurial